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Section 1 - Product Overview

To ensure that your D-ViewCam Standard/Standard/Professional/Enterprise system can maintain high video monitoring 
and recording performance, certain minimum system configurations are required.

Product Overview
System Requirements

Note: To determine the minimum hardware requirements for your planned surveillance system if it is not listed in the 
above table, please consult the SI (system integrator), the reseller, or D-Link Technical Support. 

Note: Recording video over a long period of time will consume large amounts of disk space. Make sure that you have 
enough disk space available if you want to use the recording function. You can still complete the installation even if 
you have less than the suggested free disk space.

CPU Intel Core 2 Duo E5300

RAM 2 GB

Motherboard Intel P55, H55, X58, P45, P43 chip, MB vendor ASUS Gigabyte or MSI 
with Intel Chipset recommended

Display card ATI Radeon 4650 or above (ATI Driver V11-2 recommended) 

Ethernet 100Base-T or above, Gigabit LAN recommended

Hard Disk 250 GB or above

OS 32 bits: Microsoft Windows XP pro SP3/ Vista SP1/ Win 7 SP1 
64 bits: Win 7 SP1/ Win Server 2008 R2
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Section 1 - Product Overview

Introduction

Thank you for purchasing D-ViewCam Standard/Professional/Enterprise. This state-of-the-art video management 
software is a comprehensive surveillance system designed to centrally manage up to 8/32/64 network cameras, while 
displaying real-time information on the screen. This software allows you to build a powerful surveillance system at your 
home or small business by using D-Link network cameras and the latest features offered by the D-ViewCam Standard/
Professional/Enterprise software.

•  D-ViewCam Standard/Professional/Enterprise automatically locates and adds network cameras in the local network
• Storage management for recording files
•  Single and multiple video stream monitoring (up to 8/32/64 video channels)
•  Two-way audio communication
•  Intelligent filter and search capabilities for scheduling recording and/or event recording-

Key Features
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Section 1 - Product Overview

Installing Your Network Camera 

Before installing D-ViewCam Standard/Professional/Enterprise, please make sure you have installed your D-Link 
network camera(s) that will be managed by D-ViewCam Standard/Professional/Enterprise. 

Step 1 - Follow the installation procedures that came with your network camera(s) to complete the camera   
   installation process.
Step 2 - Verify that you are able to view the video images from the network camera (s) by accessing the      
   camera’s web-based configuration utility. It is recommended that all network cameras be installed in        

the same subnet as your management PC running the D-ViewCam Standard/Professional/Enterprise     
   software.
Step 3 - Please refer to the Add camera(s) section in the next section Software Installation for more  

information.
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Section 2 - Installation

Turn on the computer and insert the CD into the CD-ROM drive. Click “Install D-ViewCam Standard/Professional/Enterprise”  
from the menu, and select “D-ViewCam Standard/Professional/Enterprise” to install the VMS (Video Management Software) 
software.
Step by step instructions are shown below if you are using Windows® XP. However, similar instructions and windows are 
displayed for other Windows operating systems.

Software Installation
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Section 2 - Installation

2. Click I accept the terms of the license agreement 
and then click Next to continue.

1. Click Next to continue.
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Section 2 - Installation

4. Select Complete to install the entire D-ViewCam Standard/
Professional/Enterprise software package or Custom to 
choose which programs to install. Click Next to continue.

   COMPLETE SETUP TYPE
    Select Complete to install all  the program features into the 
   default directory (requires the most disk space) and click 
   Next to continue.

   CUSTOM SETUP TYPE
   Select Custom to install the system to a preferred directory.
  This option allows you to specify the program feature(s) for
  installation, and is recommended for advanced users.

3. Enter your name and company name. Click Next to 
continue.
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Section 2 - Installation

7. Select the features you want to install and click Next 
to continue. The five main features in the server setup 
process are:

    
• Main Console
• Playback
• LiveView
• Backup
• Verification

5. Select Custom, and then click Next. The Choose 
Destination Location window will appear.

6. To install to this folder click Next. To install to a different 
folder, click Change and select another folder.



13D-Link D-ViewCam Standard/Professional/Enterprise User Manual

Section 2 - Installation

9. Click Finish to complete the installation.

8. Click Install to start the installation.
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Section 2 - Installation

Remote Desktop Viewer Installation

Remote Desktop Viewer allows for remote access to the Main Console and Setup configuration.

1. In the InstallShield Wizard screen, click Remote Desktop 
Viewer and then click Next to continue. 

2. Select I accept the terms of the license agreement. Click 
Next to continue.  
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Section 2 - Installation

3. Enter the User Name and your Company Name. Click Next 
to continue.

4. Select Complete to install the entire package or Custom to 
choose which programs to install. Click Next to continue.

   COMPLETE SETUP TYPE
   Select Complete to install all  the program features into the 
   default directory (requires the most disk space) and click 
   Next to continue.

   CUSTOM SETUP TYPE
   Select Custom to change the installation directory and/
   or program features. This option is recommended only for 
   advanced users.    

5. Select Custom, and then click Next. The Choose Destination 
Location window displays.
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Section 2 - Installation

6. To install to this folder click Next. To install to a different 
folder, click Change and select another folder.

7. Select Remote Desktop Viewer and click Next to 
continue.
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Section 2 - Installation

8. Click Install to start the installation.

9. Click Finish to complete the installation.
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Section 2 - Installation

D-ViewCam Standard/Professional/Enterprise Login

Once the console loads, enter the User Name and Password and click OK.
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Section 2 - Installation

Activate Software License(s)

1. Go to Main Console > General Setting and open
    the License Manager tool.
    

2. Select On line network environment.

3. Select Input SN to enter the Serial Number, Import the SN
    file, or Import license file to activate the license. 

    
4. Click Activate. After the software license is activated 
    successfully, please restart the Main Console. 

Note: Please refer to the License Management Tool section for advanced 
settings.
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Section 2 - Installation

1. Once the console loads, click General Setting    , then 
click Setting, and select System Setting. 

2. Select the Camera tab, then click Search to find the network 
camera (s) that are on your local area network (LAN).

 The system automatically searches for all the network 
cameras that are on your local area network (LAN).

3. Select a Camera.

 Note: If your network cameras support UPnP, follow step 3. 
Otherwise, skip to step 5.

Add Camera(s)
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Section 2 - Installation

4. Select one of the network cameras that are available, enter a 
Camera Name and then enter the User Name and Password. 
Click OK to add the camera.

5. If your camera(s) does not support UPnP, you can manually 
add a camera.

 Click Insert to manually add network camera(s) that are on 
your local area network (LAN).
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Section 2 - Installation

6. Enter the following Network information for your camera:
• Name - Enter a name for your camera.
• IP Address - Enter the IP address of this camera. 

If you want to use a domain name, then select DNS 
and enter the domain name.

• HTTP Port - 80 is the default port.
• User Name - Enter a user name for this camera.
• Password - Enter a password for this camera.
• Protocol - Select TCP, UDP, HTTP, or HTTPS.

 Enter the following Device information for your camera:
• Auto Detect - Click to detect the vender and model 

information.
• Vendor - Select the vendor’s name from the drop-

down menu.
• Camera Model - Select the camera model from the 

drop-down menu.
• Video Channel - Select the video channel you want 

to assign the camera to.

7. Click OK to add your camera.
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Section 3 - Configuration

D-ViewCam Standard/Professional/Enterprise 
Interface Overview

This section will show you how to start and configure D-ViewCam Standard/Professional/Enterprise.

Enter Admin as the default username and your password. Click 
OK to log into the system.

Note: Refer to the User Account Setting section for User 
Account information.

To start D-ViewCam Standard/Professional/Enterprise, go to  
Start > All Programs > D-Link D-ViewCam Standard  > Main 
Console. 
or 
Start > All Programs > D-Link D-ViewCam Professional  > Main 
Console. 
or 
Start  > All Programs  > D-Link D-ViewCam Enterprise  > Main 
Console.
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Section 3 - Configuration

Main Console

1 Main Display Area 4 Monitor 7 Configure Smart Guard System 10 Split Screen Options

2 Log out / Exit Program 5 Playback 8 General Settings 11 PTZ Features
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Section 3 - Configuration

Select a split-screen display layout by clicking on the desired layout icon. The system provides 1, 4, 6, 9, 10, 13, 16, 17 and N split screen 
modes. To switch to a single camera display, double-click the camera’s image. To return to the previous configuration screen, press the 
Esc key or double-click on the screen again.

Split Screen Options 

Log Out/Exit Program/Minimize Window

Click to log the current user out or to close the D-ViewCam Standard/
Professional/Enterprise program.

Click to minimize the window.

  Displays 1 screen   Divides into 4 screens   Divides into 6 screens   Divides into 9 screens

 Divides into 10 screens   Divides into 13 screens Divides into 13 screens  Divides into 16 screens

 Divides into 17 screens   Divides into N screens   Switch to full screen  Rotate all screens
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Section 3 - Configuration

Monitor

Option Function

Start/Stop Monitor All Click to start or stop all monitoring functions.

Start/Stop Recording Schedule Click to start or stop the recording schedule.

Start/Stop Smart Guard System Click to start or stop the smart guard system.

Enable Secondary Display Click to enable secondary monitor display.

Open Event Report Click to open the event report which will log any events.

Open E-Map Click to open E-Map which monitors all devices with map 
indicators.

Open I/O Control Click to open the I/O control window, monitor DI/DO, and 
manual triggering of DO devices.

Lock System Click to lock the system.
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Section 3 - Configuration

Monitor
Click Start Monitor and select from the menu to start/stop recording schedule or the guard system features. You can also 
open monitor tools such as event report, E-Map, I/O control, and system lock.

Playback
Click on this icon to view the Playback Console. You can watch recorded video, search video, adjust the image of the stored 
data, save videos/pictures, print images, check log information, event records, and set up recording function. See the Playback 
section for details.

Notes:
1. To automatically activate the Recording Schedule and Smart Guard when the MainConsole starts, go to General Setting > Setting > 
System Setting > General > Startup to setup the auto-startup functions.

2. The secondary monitor will still retain and display all the functions (for example Event Report, E-map, Resource Report or IO controls) 
that are opened in the Main console, even if you exit the Main Console. 

Schedule System
Click to organize the recording time schedule and configure recorder settings. See the Schedule System section for details.

Smart Guard System
Click to add/edit type(s) of events that you want to detect and setup action(s) responding to events. See the Smart Guard 
System section for details.

General Setting 
Select to modify system settings, user account settings, save/ load configuration settings, open license manager, access log 
viewer and backup files, and configure network services. See the Configuration section for details.
Note: User Account and License Manager can only be enabled for users with administrator privileges.
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Section 3 - Configuration

System Information Window 
Displays the Current Date, Current Time, Free Disk Space, Network Camera Bitrate, and User Defined Text.

PTZ Features
 
    PTZ Camera Control
    Use this function to control the movement of PTZ (pan/tilt/zoom) cameras. 
    With cameras that support PTZ control, you can move, zoom,    
    patrol, adjust the focus, and set preset points of the cameras.

Zoom
Click on the + sign to zoom in or click the – sign to zoom out.

Preset/Go
Allows you to adjust the camera view until you are satisfied. For example, 
click Set and set the preset point to 01. Adjust the camera view again and 
set the preset point to 02. Repeat the process until all preset points are 
set. You can assign a custom name to each preset. Click Go to view the 
results of your setting.
Note: To adjust the speed settings of PTZ camera, go to General Setting 
> Setting > PTZ Config.

Patrol
Go to Add Preset Point > Set Patrol to bring up the Patrol Setup dialog. 
From the left window, select the camera(s) that you would like to have in 
the patrol group. Align the cameras in order in the right window and adjust 
the time. Rename the group name if you want. After completing the setup, 
check the Active option, and then click OK.

PTZ 
Controls

Zoom

Focus

Preset
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Section 3 - Configuration

  You can set up up to four groups of auto patrol. To start or stop, click on the Go to Preset Point icon in the Main Console,  
  and select Start Patrol or Stop Patrol.

  Auto Pan
  Go to Go to Preset Point and click on Start AutoPan to enable auto pan. Click on Stop AutoPan to stop.
  Auto Pan enables the camera to scan an area horizontally from left to right or right to left.  

  Focus
  You can select to focus the camera near, far, or have it auto focus. Click on the + sign to focus near, click on the - sign to   
  focus far, and click on the center icon to auto focus. To focus near means objects that are closer will be clearer than   
  the objects that are further away. In contrast, to focus far means objects that are further will be clearer than the objects that 
  are closer. Click on the Focus icon and select auto focus if you want the system to decide the focus point for you.
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Section 3 - Configuration

Enable Move 
With cameras that support PT function, click Enable Move to adjust the current camera’s view by clicking on the display screen. To cancel 
this function, right-click on the screen and select Disable Move. 

Enable Talk
With cameras that support two-way audio, select Enable Talk.

Connect/ Disconnect
Right-click on the display screen and select Connect/Disconnect to modify the connecting status of the camera.

Show Camera
Select the camera from the Show Camera menu to display video on selected window. A list of cameras will be displayed in the right 
column of the monitor display. 

Delete Camera
Click Delete Camera to remove a camera from the display window. 

On Screen Menu
Right-click on the camera screen to view the On Screen menu, from which you can quickly adjust the settings of your camera.
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Section 3 - Configuration

Enable Digital PTZ
To enable the PTZ functions of the camera, select Enable Digital PTZ. Use the mouse wheel or click on the + and – signs to zoom in and 
zoom out on the camera. The screen flashing in the video grid indicates the corresponding view of the camera.

Fix Aspect Ratio
Enable Fix Aspect Ratio to view the original ratio video or disable this option to stretch 3:4 to fit window.

Snapshot
Select the snapshot function to capture a screen shot of the current video. You can either copy this image to the clipboard or save it. You 
may select the OSD option to export the image with date/time and camera number/name information. If the digital PTZ function is enabled, 
you can select either Full size or Selected region as your snapshot region.

Manual Record
Select to start recording video.

Toggle Fullscreen
Select to view live video(s) in fullscreen. Press ESC to go back to the original window.
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Section 3 - Configuration

Duplicate Camera
To duplicate the feed from a camera, right-click on a blank area of the screen and select Duplicate Camera. Select the appropriate camera 
to duplicate the feed from. The duplicate view from the camera will then be displayed adjacent to the original view. 
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Section 3 - Configuration

Live Display
Live display allows you to change channels and screen divisions on the Main Console and secondary monitor. Each screen division 
will have the same display list, but different sequence. The maximum number of screen divisions supported by the Main Console and 
secondary monitor is 64. For example, when using Show/Delete Camera to edit the camera list, the administrator can apply this function 
to all different screen divisions. Refer to the On Screen Menu section for more information on Show/Delete Camera.

Note: The camera list of all divisions is the same as the right column of monitor display on General Setting > Setting window. This means, 
two monitors could have two different lists. 

Action Current Division Other Division

Show camera 
(add cam 1)                     

Duplicate camera 
(duplicate cam 2)

Delete camera 
(delete cam 2”)

When using mouse to drag camera channel, the sequence change would only apply to original division.

Original Action Current Division Other Division

Right click on the camera screen and get the On Screen Menu, from which you can quickly adjust the setting of camera. 

Add to first free
channel

Add to first free
channel

Remove cam 2 and 
keep channel free

Drag cam 1 to cam 4

No change in sequence
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Section 3 - Configuration

Configuration
Click       to configure your settings.
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Section 3 - Configuration

General
Go to General Setting > Setting > System Setting > 
General.

Startup
Main Console: Select to view the Main Console system at 
startup.

Select the functions and network services that should activate 
automatically.

Full Screen: Select to launch video in fullscreen.

Auto Login Setup

Auto Login: Select Auto Login and then click Setup to view 
the Auto Login Setup window.

Enter the User Account and Password to login automatically 
when the system starts. Enable Minimize after login to minimize 
the Main Console window after login.
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Section 3 - Configuration

Enable Disk Load Balancing: If you have more than one drive available for recording, you may check this 
to evenly distribute the recording onto multiple drives. This will increase the system efficiency.
 
Automatic Recycle: The system will automatically delete out-dated data to save storage space. 

• Recycle when disk space is less than: Select and enter the available space (in MB). When the available 
space in the default folder is less than the entered value, the system will begin storing data in another 
folder specified in the location list. If all the folders exceed their storage capacity, the system will start 
recycling in one hour.

• Only keep video for: Deletes video records that are older than the number of days set. If the default 
storage space is exhausted (disc space is less than 1200 MB), the system will start recycling in an hour’s 
progress. 

• Advanced Recycling Setting: Click  Log Recycling to keep specific or all event logs for specified 
time interval.

1. Event Log: Delete the event log data that is older than the number of days set.
2. System Log: Delete the system log data that is older than the number of days set.
3. Resource Report: Delete the Resource report data that is older than the number of days set.

Storage

New Click to add a new location. Click the ... to browse to a folder. Click 
OK to save the location.

Delete Highlight a location and then click Delete to remove the file.

Move Item Up Highlight a location and click Move Item Up to move the location 
higher in the list.

Move Item Down Highlight a location and click Move Item Down to move the location 
lower in the list.

Location:  Assign a default folder for the system to store data. It is recommend not to save to the system 
drive (C:\) to avoid an efficiency drop when free storage is low.
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Section 3 - Configuration

Miscellaneous

Automatically Popup Event Report: The Event Report will automatically popup when events have been detected. Make sure to stop 
the Smart Guard system before you modify this setting, otherwise the modification will not take place.  

Minimize to system tray: Enable this option to display an icon in the task bar.

Note: Enter the username and password of the Main Console when you click the minimized icon in the task bar to start monitoring.

Synchronize video frames: Select to prevent tearing that may occur in the video display. However, this will increase the CPU processing 
load.

Status Display

Select the information that you wish to display on the Main Console such as Current Date, Current Time, Free Disk Space, Network 
Camera  Bitrate, and User Defined Text.

Start CMS 
service

Start Live 
Streaming 
service

Start Remote 
Playback 
service

Start Remote Desktop 
service
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Section 3 - Configuration

Audio Preview

Default Channel: Select the audio channel that you wish to hear from. 

Enable Audio on Active Channel: Select the Enable Audio on Active Channel to hear the audio from the selected video channel on 
each video grid of the Main Console. The default channel plays if the video channel isn’t selected. 

Volume: Use the volume bar to adjust volume.

System plays audio of the default channel System plays audio of  the selected channel

DDNS Service: Dynamic Domain Name Server (DDNS) allows you to use Live View or Web View 
to connect to the Main Console using the Internet even if you have a dynamic IP address.

Click DDNS Service to open the Dynamic DNS Setup window. 

Update the following fields - Provider, User name, Password and Host name, and Update period.
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Section 3 - Configuration

Auto Reboot

Select Enable Auto Reboot and set the day and time to reboot the system.

Note: Please enable Main Console, Auto Login, and other functions in the Startup section to ensure that the system runs normal after auto reboot.
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Section 3 - Configuration

Camera
Go to General Setting > Setting > System Setting > Camera.

Add Camera
The Search, Insert, Delete and Config functions are included in the Setting window.

Search: Click Search to open the Search Network Camera window. The system will start scanning automatically once the window is 
opened. You may manually stop scanning by clicking Stop Scan. 

Enter the user name and password for each Network Camera found and click OK to add it to the camera list.

 Drag the mouse to multi-select the cameras and then insert the username and password. The username and password will be applied to all the 
selected cameras automatically.
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Insert: Click to open Network Camera / Video Server Setting and add network cameras to the list. 

Delete: Click to remove the selected network camera(s) from the system. Click OK to finalize the modification.

Config: Click to open Network Camera / Video Server Setting. Here, you can modify the network camera settings.

Network Camera  /  Video Server Setting

Network: Update the fields, including Name, IP Address, Http Port, User Name, Password and Protocol referring to the instructions 
provided by the camera manufacturer. Select Use DNS to use domain name instead of IP address.

Device: Choose the network camera  manufacturer from the drop-down menu. Click Auto Detect and the model name will be displayed 
in the list.

Description: Displays information about the device.
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Camera List: Displays all the cameras that are connected to the system. Click the name of the camera to edit the settings.

Camera Name: Name the camera for your convenience.

Go to Web Interface: Go to the web-based interface of your camera to configure the settings (optional).

Camera Settings: Edit the camera’s parameters given by the camera vendor. Refer to the next page for more detailed information.

Video Parameter: Adjust the video’s brightness, contrast, saturation, and color hue values.

Camera Parameters
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Video Format: Select the video format for the footage.

Frame Rate: Select the frame per second.

Resolution: Select the resolution.

Bitrate Mode: Select the bitrate mode.

Bitrate: Select the bitrate amount.

Camera Settings
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Image Adjustment: Enable image to be flipped or mirrorred.

Audio: Enable microphone or speaker if your camera has these features.

Fish eye Setting (for fish eye cameras only)

Mount Type: Select whether the camera is being mounted on a wall, ceiling, or on a desktop. 

Display Mode: Select the display mode from 1O (fisheye mode shows the full camera view), 1R (normal mode shows a view similar to a 
standard camera), 2P (panoramic mode shows a full 180-degree mode across 2 panels), 1O 3R (multi-view with Fisheye mode shows a 
multiple window view with fisheye in the top-left panel), and 4R (multi-view).
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Select the information that you wish to see on the on-screen display. Click Font to select the font style.

OSD (On-Screen Display) Settings 
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I/O Device
Go to General Setting > Setting > System Setting > I/O Device.

I/O Device Setting: 
• Module: Name of the module and ID of the digital input/output device(s) that is connected to your system. 
• Device: This column displays the device(s) already installed to the system.
• ID: Select the I/O port.

Input Monitor: The device(s) is turned on if the dot is in red. By triggering the digital input device, the related icon will light up. This is 
used to check if the device is correctly connected or not.

Output Monitor: The device(s) is turned on if the dot is in red. By clicking on the icon, you may trigger the digital device connecting to the 
system. This can be used to test if the output device is correctly connected.

Device Setting 
Name: Insert the name of the device (input and output).
Type: Select the device type from the drop-down menu. 

1. N/O: Normal Open
2. N/C: Normal Close 
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PTZ Config
Go to General Setting > Setting > System Setting > PTZ Config.

Select a PTZ camera from the list to activate the PTZ control function.

Basic Setting
Select the camera model, com port, baud rate, and address of your PTZ camera. 

Note: If your camera model is a network camera, the PTZ function will work without the com port, baud rate, and address settings.

Advanced Setting
Adjust the pan speed, tilt speed, and zoom speed settings by dragging the bars.
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User-Define Preset

Step 1: Enter a Preset Name.

Step 2: Enter the Preset Number.
 
Step 3: Click OK to save your preset.

Click Add to add a new preset. Select the preset you want 
to remove and click Delete, or highlight a preset and change 
the preset name and/or preset number and then click Update 
to save.

Miscellaneous

Patrol Group: Click to setup a patrol group.
From the left window, select the camera(s) that you would like to have in 
the patrol group. In the right window, align the cameras in order and adjust 
the time. Rename the group name if you want. After completing the setup, 
select Active to trigger functions such as Auto-tracking and Login of the 
camera, and then click OK.

You can set up to four groups of auto patrol. To start or stop, click Patrol 
in the Main Console, and select Start Patrol or Stop Patrol.
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Hotline
Go to General Setting > Setting > System Setting > Hotline.

Use this window to configure the Hotline settings when an unusual event is detected. 

E-Mail: Enter the following information - SMTP server, port, sender’s e-mail address, subject title, body content and SSL for encrypted 
transmission. Click Send Test Mail to test the settings.

GSM modem: Set the Port and Baud Rate of the GSM modem device, and then enter PIN code. You can also enter the time for sending 
a SMS message. Click Test to send a test SMS message.

Note: The Interval is set to restrict the time period while sending two SMS messages. For example, if you set as 60 min, the SMS sent 
between 60 min will be deleted and not sent to the user.
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Address Book
Go to General Setting > Setting > System Setting > Address Book.

Use this window to update name, phone number and e-mail address information. When an unusual event is recorded, an e-mail notification 
will be sent out by the system.
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Monitor Display
Go to General Setting > Setting > System Setting > Monitor Display.

Playback Option: Execute Playback feature on the secondary monitor by selecting the Secondary tab. Make sure to adjust your computer 
display settings (supports 800x600, 1024x768, 1200x900, 1280x1024 and 1600x1200 monitor resolutions) in advance to avoid system error.

Cameras List: The left column displays a list of all available cameras. Highlight the camera and click --> to move the camera to the right 
column. The right column will display the primary and secondary cameras. These cameras will be available for the auto-scan function.

Auto Scan: Activate auto scan to rotate the channels/cameras on the display screen. 

For example, you may select to show only 4 sub-screens on the Main Console while having 16 channels connected to the system. With 
auto scan function, you will be able to see all the 16 channels. You can set up a primary channel that will always be on the screen and a 
secondary channel that has secondary priority. 
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User Account Setting
Go to General Setting > Setting > User Account.

Only an administrator can manage user accounts. From the Privilege list, highlight each account to modify.
Note: The system by default, will display the account group’s default privilege profiles. Enter a Name and Password to create a new account, or 
click an existed account to modify his/ her privilege.

There are 3 default profiles for account groups:
Admin: The Administrator has privileges to all system functions and devices, except add/delete/update privileges of other users.
Power User: A user has limited privileges to system functions and complete privileges for assigned devices. 
User: Privileges for all the system functions are forbidden, user can only manage devices.

Add: Click to create a new account after updating the information. 
Delete: Click to delete the account.
Default: Click to go back to default privilege settings of a related user group.
Update: Click to save the modifications of each account.
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User Account
To create and modify user accounts. 

User Name: Enter a name.
Group: Assign a group for each user.
Description: Enter a description.
Password: Enter the password assigned to the user.
Password Confirm: Enter the password again for 
confirmation.
Disable User Account: Select to block this account.

Note: Only the default admin account cannot be disabled.
Keep remote login for___minutes: Enter the duration to
auto logoff after logging in from Remote Live Viewer or 
Remote Playback.

Privilege
Select to set privileges for each user account. 

Function: Set the system configuration, and privileges for 
remote access.
Device: Set device privileges for camera, digital output and 
client applications.
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Auto Backup Setting
Go to General Setting > Setting  > Auto Backup Setting

To configure your system to automatically back up video data.

There are 3 main options in Auto Backup config:
Enable Schedule Back Up: Check to enable the backup process.
Select Camera(s) to Back Up: Select the camera to back up. 
Option: Select options for backup.

• Location: Define backup route.
• Backup Playback System: Check to backup the playback application with each process.
• Send Mail when Backup Fails: Check to receive an email notification when backup fails. Click Setup for email 

configuration. Select one or more contacts from the address book and configure customized message content.
• Recurrence: Choose start time and Recurrence: Daily or Weekly modes.
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There are 4 main fields in Auto Backup Statistic:
Current Backup Status: Displays whether the 
backup is underway, idle, or awaiting retry. 
Next Backup Start Time: Displays the 
scheduled time for next backup process. 
Next Retried Process Time: Displays the 
scheduled time for next backup retry process.
Last Backup: Displays information 
about the most recent backup.

• Last Backup Start: Displays the time 
and date the last backup started.

• Last Playback Stop: Displays the time and 
date the last backup was completed.

• Backup Video Period: Displays the total 
time that the last backup took to complete.

• Backup Size: Displays total file size of last backup.
• Backup Result: Displays the 

result of the last backup.
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License Manager
Go to General Setting > License Management in the Main Console to activate the license. The serial number can be found on a sticker, 
located inside the CD case.

Note: Please refer to the License Management Tool section for details.
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Save/Load Configuration

The Save/Load Configuration function allows system users to save any specific setting as a .cfg (config) file. You may save several 
different .cfg files at any time.

Save Configuration: To save a specific setting, go to General Setting > Save/Load Configuration > Save. In the popup window, 
type in the file name and then save it as a .cfg file.

Load Configuration: To load a specific setting, go to General Setting > Save/Load Configuration > Load. In the popup window, 
go to the directory that you saved the .cfg file at, select any one of them and then click OK to load the file. 

Note: The Main Console will be automatically shutdown after loading a new configuration. Please re-start  the Main Console manually.
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Network Service

There are 4 types of network services: Live Streaming Server, Remote Playback Server, Remote Desktop, and Central Management. 
From the Main Console, go to General Setting > Network Service to open the Network Service window.

Live Streaming Server
With Live Streaming, the system allows remote users to log in to a specific computer and view cameras that are connected to it. As a 
System Administrator, you can monitor these accounts in order to maintain the efficiency of the system.

Main
From the Live Streaming Server window, administrators can view all the clients who have logged in. It also enables 
Administrators to view live video from a remote location.
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Client List
Client Count: Shows the number of channels that are connected.
Kill: Highlight an IP address and click Kill to block the client from your 
client list.
Kill All: Click to block all the clients that are currently logged in to your 
system.

Service
Server Status: Click Start/Stop to turn on/off the server.

Options
To modify this section, click Stop to stop the server.

Port: Assign a port for the client to connect to your system via Remote 
Live Viewer. Default port is 5150. 
Maximum Connections: Number of connections that are allowed to 
connect to the system. The maximum is 128, one camera video counts 
as one connection. 
Use Default Web Server: Activate the Web server by selecting this box. 
Clients will be able to watch live video via Internet Explorer. The default 
port for live streaming server is 80. 
Save Log: Select to save the current log information to your computer.
Enable Audio: Select this option to enable audio transmission along 
with video stream. 
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Enable White List: Select to activate the white list filter. Only IP address from this list is allowed to log in. 
Enable Black List: Select to activate the black list filter. The IP address from this list will be blocked. 
IP Address: Enter an IP address or two sets of IP address to indicate a series of IP addresses.  
Add/Delete: To add the IP address into the list or to remove from the list.
Apply to All Network Servers: Click to apply these settings to both Live Streaming Server and Remote Playback Server.

Live Streaming - Black / White List
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Live Streaming - Performance

This window displays the Total bitrate and individual Camera bitrate information.
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With the Remote Playback function, the system allows remote users to log in to a specific computer and withdraw data files that are stored. 
As a system administrator, you can monitor the accounts logged in to maintain the system efficiency.

Main
This window displays all the clients who are currently logged in and watching a playback video from a remote location.

Client List
User Count: Displays the number of users that are connecting to the system.
Kill: Highlight an IP address and click Kill to block the client from your client list.
Kill All: Click to block all the clients that are currently logged in to your system.

Service
Server Status: Click Start/Stop to turn on/off this service.

Remote Playback Server
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Options
Port: Assign a port for clients to connect to your system via Remote Playback. The default port is 5160. 

Maximum Users: Number of connections that are allowed to connect to the system. The maximum is 64. 
Note: A single user logged in to the server is considered as one account.

Use Default Web Server: Activate the Web server by selecting this box. Clients will be able to watch live video via Internet 
Explorer. The default port is 80. 

Save Log: Save the current log information.
Note: Ensure that the server is stopped before making any changes.
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Remote Playback - Black / White List

Enable White List: Select to activate the white list filter. Only IP address from this list is allowed to log in. 

Enable Black List: Select to activate the black list filter. The IP address from this list will be blocked. 

IP Address: Enter an IP address or two sets of IP address to indicate a series of IP addresses. 

Add/Delete: Add the IP address into the list or remove from the list.

Apply to All Network Servers: Click to apply these settings to both Live Streaming Server and Remote Playback.
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Remote Playback - Performance

This window displays the Total bitrate and individual Camera bitrate information.
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This window allows remote users to use Remote Desktop Viewer to login and configure the system. Refer to the Remote Desktop Viewer  
section to install and use this tool.

Options
Port: Assign a port for  Remote Desktop Viewer, so that users can login and configure system. 
Disconnect idle client after (300~3600 sec): Auto disconnects an online user who is idle for more than the specified time period. 
Authentication: Enable this option to allow only an administrator to login into the system.
Server Status: Click Start/Stop to turn on/off this service.

Remote Desktop
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This service only supports Central Management System (CMS). With this service, the Main Console will send event information to CMS 
and allows the CMS system to control the I/O device from a remote location. To enable this action, go to Configure Smart Guard System 
> Action and select Send to Central Server.

Client List
Client Count: Displays the number of CMS Servers that are connected to the system.
Kill: Highlight an IP address and click Kill Client to block the client from your client list.
Kill All: Click to block all the clients logged in to your system.
Server Status: Click Start/Stop to turn on/off this option.

Options
Note: Ensure to stop the server before modifying the settings.
Port: Assign a port for the CMS System to connect to the Main Console system. Default port is 5170. 
Maximum Connections: Number of connections from CMS Servers that are allowed to connect to the system. The maximum 
is 16. 

Central Management System
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About Main Console

Go to General Setting > About Main Console to view the version of your D-ViewCam Standard/Professional/Enterprise software and 
model name information.
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Schedule System
Click the Configure Schedule System icon on the Main Console to set up the time duration for video recording.
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Day Mode
Schedule the camera(s) to record video every day at the same time.

There are three ways to setup the time schedule for each camera:
1. Load a preset mode 
2. Insert a new schedule manually 
3. Copy to other cameras after the manual setup

1

2

3
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Mode Format Time Record FPS Quality Resolution

Regular
M-JPEG

0:00 - 24:00 Always
Max

Max Max
MPEG-4 Max

Office
M-JPEG

8:00 - 20:00 Always
Max

Max Max
MPEG-4 Max

Shop
M-JPEG

10:00 - 22:00 Always
Max

Max Max
MPEG-4 Max

Highly Secure
M-JPEG

0:00 - 24:00 Always
Max

Max Max
MPEG-4 Max

Disk Saving
M-JPEG

0:00 - 24:00 Motion
10

Max Max
MPEG-4 i-frame

Minor
M-JPEG

0:00 - 24:00 Motion
5

Max Max
MPEG-4 i-frame

Load Preset Modes
The system provides six modes to quickly setup the recording schedule. Click                to select the preset mode. Refer to the following 
table for definitions of each mode in each series.
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Insert a New Schedule Manually

Step 1
Left-click and draw the bar you want to add to the time table. The scheduled time will be seen as a grey bar.

Step 2
Click Insert and add a new schedule in regular mode, i.e. to record video during the time period you set with 30 FPS, normal video quality, 
and normal resolution.

Step 3
Click on the Configure icon or double-click the schedule information to change the settings.

Step 4
Click OK.

12
3

4
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Copy Schedule
You may set up the schedule for each channel/camera by repeating the process above, or simply apply the settings of a single camera 
to all the others by clicking the Copy To icon on the top of the display window.

Week Mode
Schedule the camera(s) for each day of the week. In addition, you may assign holidays under the Week Mode.

Default
Follow the same process to setup the schedule for every day in a week.

Holiday 
You may assign holidays where the system will work according to the pre-defined Sunday schedule.

Custom
You can assign a particular date(s) for the system to work according to a special schedule(s).
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Adjust the Schedule Settings
You can manually change the settings at any time after you insert or load a schedule.

Option 1: Select the Time Bar and slide the bar to the left or right to change the start and end points.

Option 2: Click Configure or double-click on the schedule information (highlighted in blue) to open the Encoding Options 
window and modify the settings.
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Encoding Options

Pre-record/Post-record Time
The pre-record/post-record function lets you save the recording data accordingly. For example, a 5 second pre-record means the system 
will start saving the recording 5 seconds prior to the event. 
Note: The maximum recording period is 60 seconds.
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Record Mode
Always Record
Select this option to record video continuously.

Record on Motion
Select this option to start recording when motions are detected. Please adjust the Sensitivity, Frame Interval and set up a 
detection zone to detect Motion. Frame interval is the interval in the number of frames between each check by D-ViewCam. 
To create a detection zone, left-click and drag the mouse to draw a rectangle on the display screen. To setup multiple 
detection zones, simply repeat the same process or click All to select the entire detection zone.
Note: The number of detection zones cannot exceed 10.

Encoded Options
Use this option to configure the quality of video. The original video is the original stream from the camera and the encoded video is a 
preview of the recording video that correspond to the encode settings.

Keep original video format
Select this option to lower the frame rate but not re-encode the video stream to save Hard Drive usage.

• Adjust MJPEG video frame rate: Use the slider to reduce or increase the frame rate.
 Note: The maximum FPS (move the slider to the right) will correspond to the original video stream setup on camera 

configuration.

• Keep key-frame only: The System will record only the key frames of the streaming video.
 Note: The key frame interval is controlled by each camera manufacturer and cannot be adjusted.
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Playback
The Playback console allows you to watch recorded video, view and/or search for unusual events, and view recorded system information.

1 Exit Playback 5 Speed 9 Information Window 13 Screen Division 17 B a c k u p  &  L o g 
Viewer

2 Minimize Window 6 Play/Rewind/Fast Forward 10 Open Record 14 Enhancement

3 Cue (Start/Stop Point) 7 Zoom 11 Search Mode 15 Setting & Save Video

4 Control (Play/Stop/Pause) 8 Scroll Bar 12 Volume Control 16 Snapshot & Print

1

2

3

4

5
6

7

8 9

12

10
11

13

14
15

16
17
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1. Exit: Click to close the Playback window.

2. Minimize: Use this to minimize the Playback console.

3. Cue: When playing video, click on the Cue In/Cue Out icon to set the starting/ending point of a saved video clip. The Cue In and Cue 
Out time will be displayed on the Playback Information Window.

4. Control: Use this to play, pause, and stop the video.

5. Speed: Control the speed of the playing video. Click + to speed up and – to slow down.

6. Play/Rewind/Fast Forward: Use this to control the video.

7. Zoom: Use this to zoom in and out of the recorded video. 

8. Scroll Bar: Indicates the status of the playing video; drag it to where you want to review.

9. Information Window: Displays video date and time, current video status, cue in/out points’ time, and speed.

10. Open Record: Click to access Date Time.

11. Search Mode: Click to open Intelligent Search Tool. 

12. Audio Volume Control: Use this to adjust the sound level.

13. Screen Division: Allocate the sub-screen display by clicking on the desired layout. To switch to a single camera display, double click 
on a particular sub-screen. Double click on the screen again to restore the previous screen division layout. To view in fullscreen mode, 
right click on the screen to enable Toggle Fullscreen.

14. Enhancement : Click           to open the Enhancement window 

15. Setting & Save Video: Click          to open the Setting window and            to open the Save Video window.

16. Snapshot & Print: Click          to take a picture and          to open the Print window.

17. Backup & Log Viewer: Click          to open the Backup window and          to open the Log Viewer window.



79D-Link D-ViewCam Standard/Professional/Enterprise User Manual

Section 3 - Configuration

Date Time

Record Display
The record display window displays information about the video clips. These clips can be sorted by 
date (calendar view) or title (list view). 

 Remote Server Site: Select to open Remote Playback Site Management. This site allows 
you to access local PC or set up the remote playback server. Use Select Folder to directly 
access the recorded data folder or Recent List to access previously browsed recorded folders.

 Note: To use Select Folder option you need the Main Console password.

 Refresh: To refresh the Record Display window.

 Log Viewer: To access the Log Viewer Tool.

 Previous Days: To show recorded videos from the previous recording date.

 Next Days: To show recorded videos of the next recording date.

Go to Playback console and click Open Record                     to access the Date Time Search Dialog. Here, you can review video records.
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Date Time Period
Select the starting and ending time points to review a video.

Video Preview
Select Enable Preview to preview the selected video.

Event Type
You can change the color of the event by clicking on the color bar and then click the down arrow. 

Time Table
• Click      to select all channels or       to deselect all channels. Finally, utilize the                                scale bar to modify the time 

table.

• Select Show Records to display the time period of recorded data.
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• Select Show Event Log to display the time of event detected.

To Playback Video

Step 1: From the Record Display window, select the date of the recorded video you want to view. The red, green and blue 
lines in the time table indicate the available video records.

 Note: The Record Display window can be displayed in (a) calendar view or (b) list control view. To modify these 
settings, click Settings on the Playback Console. 

Step 2: Use color bars to differentiate event types. 

Step 3: Highlight the video clip you want to review by left clicking and dragging the time period. You may also utilize the 
Start Time and End Time in the Date Time Period section. 

Step 4: Select Enable Preview in the Video Preview section to view your video.

Step 5: Click on the camera name to add or remove cameras that you want to playback.

Step 6: Click OK when finished.
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Search Mode
Go to Playback console and click Search Mode   to open the Intelligent Search Tool window. 

Intelligent Search Tool
Use this tool to detect unusual events that occur during the recording period.

Alarm Event Type
 
General Motion: Detects all movements in the defined area.

Sensitivity: This slider controls the sensitivity required to trigger the alarm. Slide 
the control to the right to increase sensitivity (relatively small movements 
will trigger the alarm) or to the left to reduce sensitivity. 

Interval: Move the slider control to the right to increase the time interval, so
the alarm will be triggered only when the movement lasts longer; moving
to the left will reduce the time interval.

Define Detection Zone: Left click and drag, to draw a detection zone on the  
video screen. You may define more than one zone on the screen by repeating 
the process.

 
Stop When Found: Select this option to stop the video when detecting motion 
in the detection zone. Unselect this option to keep the video rolling, and to 
display all the detected events on the search list. Click on the listed event to 
jump to the specific part in the video where motion is detected.
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Enhancement
Go to Playback console and click  to open this tool.

General Setting
Select to either apply the filter settings to only active channels or to all channels.

Filter Setting
Visibility: Select to adjust the gamma value of the image to enhance the 
image and make it cleaner.

Sharpen: Select and move the slider control to the right to sharpen the image 
or to the left to soften the image.

Brightness: Select and move the slider control to the right to make the image 
brighter.

Contrast: Select to move the slider control to the right to increase contrast.

Grey Scale: Select to display the video record in grey scale mode. The image  
will be displayed in black and white.

Default: Click to restore the default settings.

OK: Click to save to apply your settings.
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Step 3: Click the Save Video icon, select the location where you want to save the file to and 
enter the file name.  

Step 4: Select Export Format from the drop-down list - ASF or AVI.

Step 5: Select a profile from the Use Profile drop-down menu.

Step 6: Select to export (i.e. save) the recorded video with audio, OSD (On-Screen Display), 
or export video only.

Step 7: Click OK to save video.

Save Video
Go to Playback console and click           to open this window.

Step 1: Click on the display screen of the Playback console to choose the camera display that you want to save as a video clip.  

Step 2: Click the cue buttons to select the start and end points. The cue in and cue out time will be displayed in the information window.

Cue in Cue out

Save Video
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Snapshot

Go to Playback console and click           .

Step 1: Click on the camera display window to take a snapshot.

Step 2: Click Save Image when the image you want is displayed on the screen. You may click Pause to freeze the video and use Step 
Forward/Step Backward to find the picture(s) that you want to save.

Step 3: Select OSD to export the image with the date/time and camera number/name displayed. If the digital PTZ function is enabled in 
the display view, you can also select Full size or Selected Region as your image region.

Step 4: You have the option to copy the image to the clipboard or save it to your computer. Click Save Image and select the folder you 
want to save it to. Select the image format (BMP or JPEG) and click Save.

Note: You may skip step 3 by pre-setting a folder and format to save images.
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Print
Go to Playback console and click           to open this window.

Page Setting: Select Original Size or Fit to Page options to print the image. 
Select the alignment from the Align Image drop-down list (Top, Center, or 
Bottom).

Print Content: Print the image from the selected channel or all the channels 
shown on the screen.

Print: Click to print the image.

Backup
Go to Playback console and click          to open this window.

Here, you can start a full function Playback Console and load the backup files on any Windows PC. You can monitor real time video and 
work on the backup files on separate computers simultaneously. 

Step 1: Click Open Record in the Playback console and click Backup.

Step 2: In the Date Time Period section, select the Start Time and End Time for backup.

Step 3: In the Select Camera(s) section, select the camera(s) you want to backup.

Step 4: Click Calculate Size to calculate the size of the backup data.

Step 5: Under Media, select where you would like to save the backup data.

Step 6: Under Option, select the type of data you want to backup.

Step 7: Click Backup to start backup.

3

2

4

5

6
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Log Viewer
Go to Playback console and click  to open this window.

Unusual Event
The Smart Guard System displays the history of all the unusual events’.

Step 1: Select the type of events you wish to view or select All from 
the drop-down menu to view all types of events. The types 
of unusual events include General Motion, Signal Lost, 
and Digital Input Triggered. 

Step 2: Select the camera channel you wish to view or select All to 
view all the available channels.

Step 3: View the events that happened on a particular date or during 
a given time period by selecting Search. 

 Date: Select Date and indicate the date.
 DateTime: Select the date and time.

Step 4: Click Search.

Note: The Log Viewer in Date & Time mode will search for all the 
unusual events that are recorded. The system, by default searches 
the record from the beginning to the end. A link will appear next to 
each event. By clicking this link, the video will jump to the point where 
an unusual event takes place.
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System Log

There are 29 Log Types in the drop-down menu:
1. Main Console Startup
2. Main Console Shutdown
3. User Login
4. User Login Failed
5. Start Schedule
6. Stop Schedule
7. Execute Recycle
8. Enable Channel

9. Disable Channel
10. Start Smart Guard
11. Stop Smart Guard
12. Modify Smart Guard
13. Modify Schedule
14. Modify Configuration
15.Start Live Streaming Server

16. Stop Live Streaming Server
17. Modify Live Streaming Server
18. Start Remote Playback Server
19. Stop Remote Playback Server
20. Modify Remote Playback Server
21. Network Camera  Connection Lost
22. Auto Restart Windows
23. Modify E-Map

24. Start Remote Desktop
25. Stop Remote Desktop
26. Modify Remote Desktop
27. Start Central Management 
28. Stop Central Management
29. Modify Central Management

Step 1: Select the type of event or select All from the drop-down menu.

Step 2: View the events that happened on a particular date or during a given time period by selecting search period. 

Step 3: Click Search. 

Step 4: You can export the data to a text file (.txt) or excel file (.xls). Click Export to, enter the filename, and select the format to export.
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Setting
Go to Playback console and click           to open this window.

General

Record Display

Play

• Play when open: Select this option to start playing the video clip everytime a record is withdrawn.
• Auto skip when record motion only mode: Select to set up the system to automatically skip to the points where motions were 

recorded.
• Next interval: Set the interval and click Next on the playback console to fast forward the video.
• Previous interval: Set the interval and click Previous on the playback console to rewind the video.

Capture Image

• Save in clipboard: The image will be saved in the clipboard and can be pasted to other applications.
• Manually save the image file: Select to manually save the image, and the format of the image.
• Automatically save the image file: By pre-setting the URL and the image format, the system will automatically save the image 

accordingly, when you click Save in the control panel.

List ControlCalendar View



90D-Link D-ViewCam Standard/Professional/Enterprise User Manual

Section 3 - Configuration

Miscellaneous

• Synchronize video frames: Select to prevent tearing that may occur in the video display. However, this will increase the CPU 
processing load. 

OSD 

Select Enable Camera OSD to display video information of the recording video. Information includes camera name, camera number, date 
and time. Users also can set the font, size, and font color.
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Access Remote Playback Site
Go to Open Record > Date Time in the Playback Main Console and click            to access the Remote Playback Site.
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Smart Guard System
Click the Configure Smart Guard System icon                                                to open the Event and Action Configuration window. 

Select an event to be detected and set up an Action for the D-ViewCam Standard/Professional/Enterprise system to perform.

Note: To access the Smart Guard Event Report, click Start Monitor > Open Event Report in the Main Console.
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There are 3 sources of events: Camera (video image), Digital Input (device connected to your PC) and System (condition of your 
hardware). You can assign multiple events by following the instructions below.

Event

Assign a Camera Event

Step 1: Select a channel from the camera list and click Insert Event       .

Step 2: There are two types of events: Signal Lost and General Motion. Select the event you want in the Event Type list and click OK.

Step 3: Configure the Event Type settings. Refer to the next section.
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Alarm Event Configuration

This section describes the basic setting of Signal Lost and General Motion events.

Signal Lost

Enable Event: Select to activate the event.

Life Cycle
• Automatically cancel event when event disappears: The alarm/action 

will be cancelled once the event is fixed or ends.
• Manually cancel event or event last triggered: The alarm/action will 

continue to be active until canceled. To cancel the event, click Start > 
Open Event Report > Cancel All Events.

• Cancel event after timeout xx seconds: Select and enter the time (in 
seconds) to cancel an event. 

• Always Activated: Select to have the event enabled 24 hours a day.
• Activated only in the following period: Select and choose a time 

period to have the event active.
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General Motion

Alarm Event Option
• Sensitivity: Click and move the slider control to the right to increase 

sensitivity so that a relatively small movement will trigger the alarm. 
Move the bar to the left to reduce sensitivity of motion detection. 
Setting up an appropriate sensitivity value will reduce the chances 
of a false alarm. For example, you can lower the sensitivity to avoid 
the alarm being triggered by a tree swinging in the breeze.

• Interval: Click and move the slider control to the right to increase 
the interval time so that the alarm will only be triggered when the 
movement lasts longer. Move to the left to reduce the interval time.

Region Definition
• Define detection zone: To detect General Motion, you have to 

define a detection zone. Left-click and drag the mouse to draw a 
detection zone. You may define more than one zone on the screen 
by repeating the same process. You can also click All to select the 
entire detection zone.

Click Start Simulation and test the function on the preview window.
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Digital Input

Step 1: Select to highlight Digital Input on the event type list and then click        Insert Event.

Step 2: Select the device that is connected to your camera(s).
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Action
Assign an Action Type

Insert Action: Select actions that responds to an unusual event.

Step 1: Select an event and click         Insert Action.

Step 2: Select one of the five actions and then click OK.
 

1. Play Sound
2. Send E-mail
3. PTZ Preset Go
4. DI/DO
5. Send a SMS Message
6. Send to Central Server

Step 3: Configure the Action Type if required.
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Action Type > Play Sound 

The system will play an audio .wav file when an unusual event is detected.

Step 1: Select the Play Sound action and then click OK.

Step 2: Select a wave file (.wav) and then click Play Sound to modify the setting.
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Action Type > Send E-mail 

When an event is triggered, the system immediately emails the specified recipients. The email contains the type of event, the time it 
occurred, and a picture of the event. 

Step 1: Select the Send E-mail action and then click OK.

Step 2: From the Select Contactor window select the email address(es) you want to send alerts to.

Click Edit Address Book to add, delete, or edit contacts.
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Action Type > PTZ Preset Go
Use this to trigger the PTZ (pan/tilt/zoom) camera(s)

Step 1: Select the PTZ Preset Go action and then click OK.

Step 2: In the PTZ Preset Go window, select the PTZ camera that is connected 
to your system. Then set the start and end preset points, and select the life cycle 
for the event. Click Add when you are done to add the preset to the table below. 
You may repeat this step to add another preset.
 
Step 3: When you are finished adding your presets, click OK. 
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Action Type > DI/DO 

Use this to trigger the Digital Input/Output devices that are connected to the camera(s), such as alarm lights or sirens.

Step 1: Select the DI/DO action and then click OK.

Step 2: Select Digital Input Module and then click the DI/DO indicator to modify the setting.

Step 3: Select the device that is connected to your system. Enable Automatically popup 
I/O control panel to monitor the I/O status.

You must adjust the setting of I/O device in General Setting > Setting > I/O Device first 
and the I/O control will display the device status based on this setting. You can also adjust 
the size of the window by clicking                 on the display window.
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Action Type > Send a SMS  

The system will immediately send an SMS to the user indicating the type of event, and the time.

Step 1: Select the Send a SMS message action and then click OK.

Step 2: The Select Contactor window will display. Here you can choose one or more 
contacts at once. 

Edit Address Book: Click to enter the contact information. This is similar to the Send 
E-mail and Phone Call action.

Action Type > Send to Central Server   

To send events to the Central Server

Step 1: Select the Send to Central Server action and then click OK.
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E-Map

To launch E-Map, click Start and select Open E-Map from the start menu.

With E-Map, users can track the actual location and alarm status for each camera and receive instant response when the event happens. 
The arrows and lightening icon on E-Map represent cameras and I/O devices.These icons will turn red once they are triggered by alarms.

There are 2 modes in E-Map application:

Edit mode: Allows users to add/edit maps of devices. 
Operate mode: All settings will be activated in this mode. 
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Edit Mode

Functions Edit mode/Operate mode

In Edit mode, the icons at the bottom of the window will be active for configuration when running the E-map function for the first time. 
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Add E-Map

Step 1: Make sure you are in Edit Mode and all devices are connected.

Step 2: Click Add Map to load a map image.

Step 3: Select the map file and insert the map name. Click OK, and the map you added appears in the device and map list.
 
Step 4: The map indicator appears on the left-up corner of the parent map. Drag it to the position you want on the map. 

Add/Edit/Delete Map
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Edit E-Map

Step 1: Make sure you are in Edit Mode and all devices are connected.

Step 2: Right-click on Map      to view the option menu to edit map, or just click Edit Map to open Map Config.

Step 3: Modify the details and then click OK to save configuration.

Delete E-Map

Step 1: Make sure you are in Edit Mode and all devices are connected.

Step 2: Right-click on Map       to open the option menu to delete map, or just click Delete to remove the map from the list.

Note: The root map cannot be deleted.

Add/Rotate/Delete Device Indicator

Add Indicator
Step 1: Make sure you are in Edit Mode and all devices are connected.

Step 2: Select the Map      icon to add the device indicator.

Step 3: Before adding the indicator, ensure that the map you want is displayed. Select device from the list and directly drag a device to 
the desired location on the map.

Note: Different device symbolizes different indicator.

  - Camera indicator        - digital Input indicator     
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Rotate Indicator

Step 1: Make sure you are in Edit Mode and all devices are connected. Select the device indicator from the Device and Map list. The 
device indicator will be marked with a green circle      .    

Step 2: Click Rotate, the indicator will rotate 45 degrees.

Note: Only camera indicators are allowed to be rotated.

Delete Indicator

Step 1: Make sure you are in Edit Mode and all devices are connected. Select the device indicator from the Device and Map list. The 
device indicator will be marked with a green circle      .

Step 2: Click Delete.
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Operate Mode

This window will list all the devices and map hierarchies. Click the Device or Map indicator to show related information in the E-Map window.

Device and Map Tree list

Map Select the map you want to show in the E-Map Window.

Camera Select the camera you want to preview video from the preview window.

Digital Input
Select to highlight the device with a green circle on the map and show its status in the Information 
window. If the Digital Input is from a network camera, the preview window will display live video from 
the camera.

Digital Output
Select to highlight the device with a green circle on the map and show its status in the Information 
window. If the Digital Output is from a network camera, the preview window will display live video 
from the camera.

Operate Mode/Edit Mode
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E-Map
This window displays the map layers and indicators.

Device Indicator: Select the device indicator from Device and Map Tree list to preview video and related information.

Map Indicator: Select to enter the map layer. If you want to move to the upper layer, right click on the map to select Up or click on 
the map.   

Information and Preview window

Map Info Displays map name.

Camera Displays camera name and connection status.

Digital Input Displays digital input name and status (0 or 1). 

Digital Output Displays digital output name and status (0 or 1). 
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Layout Adjustment

Shrink the window:
Click the triangular indicators            to hide the device and information windows. Click the triangular indicator again to go back to the 
default setting.

Full screen display:
For a computer system with dual monitors, you can view the Main Console on primary monitor and view full-size E-Map on a secondary 
monitor.

Step 1: Click the triangular indicators            to hide the device and information windows on the right and left side. 

Step 2: Click         located on the upper-right side of the window to switch to fullscreen mode.

Adjust layout Window
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Log Viewer

To launch Log Viewer, go to General Setting and select Log Viewer  to view the event history. These events are detected by the Smart 
Guard system.
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Unusual Event

Step 1: Select the type of event you wish to view or select All from the drop-down menu to view all types of events. The types include 
General Motion, Signal Lost, and Digital Input Triggered. 

Step 2: Select the camera channel you wish to view or select All for all available channels.

Step 3: View the events that happened on a particular date or during a given time period by selecting a search period. 

 For a particular date: Select the date you want to view. 
 For a period: Select Date&Time and then enter the date and time.

Step 4: Click Search.
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System Log
Select the Log Type from the drop-down menu. There are a total of 29 log types to choose from:

1. Main Console Startup
2. Main Console Shutdown
3. User Login
4. User Login Failed
5. Start Schedule
6. Stop Schedule
7. Execute Recycle

8. Enable Channel
9. Disable Channel
10. Start Smart Guard
11. Stop Smart Guard
12. Modify Smart Guard
13. Modify Schedule
14. Modify Configuration

15. Start Live Streaming Server
16. Stop Live Streaming Server
17. Modify Live Streaming Server
18. Start Remote Playback Server
19. Stop Remote Playback Server
20. Modify Remote Playback Server
21. Network Camera  Connection Lost

22. Auto Restart Windows
23. Modify E-Map
24. Start Remote Desktop
25. Stop Remote Desktop
26. Modify Remote Desktop
27. Start Central Management 
28. Stop Central Management
29. Modify Central Management

Step 1: Select the type of event you want to check or select All from the drop-down menu for all types of events.

Step 2: View the events that happened on a particular date or during a given time period by selecting a search period. 

 For a particular date: Select the date you want to view. 
 For a period: Select Date&Time and then enter the date and time.

Step 3: Click Search.
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Export

Here, you can export the log file to an excel (.xls) or a text (.txt) file.

Step 1: Click Export To.

Step 2: Type the file name and select the file format (.xls or .txt).
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Backup
The backup function saves video records and other log information. 

Note: The backup cannot exceed 7 days of recordings. 
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Back up Recorded File(s)

Step 1: Click Remote Server          to add a backup site.

 •  Enter the Server Name, Address, Port, Username, and Password.
 •  Click Add to add the server.
 •  Click OK to exit the Setting window.

Step 2: To access the Remote Backup Site, click          and enter the username/password of 
the remote server to access the backup site.  

Step 3: Click New Period to open Select DateTime Period.

Step 4: Select the data you want to back up by highlighting the time period. You may also set 
up a start and end time in the Date Time Period section.
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Step 5: Click on the camera number icon to add camera(s) or click                 to 
add/delete all channels.

Step 6: Select Enable Preview to display the preview of the video you selected.

Step 7: Click OK when the settings are complete. 

Step 8: Click Remove Period to remove data from the backup list.

Step 9: Click the Backup icon to open the Backup window.

Step 10: Under Media, select the path you want to save the file or burn the file 
directly to a CD (direct CD burning for Windows® XP only), DVD or to a 
hard drive.

Step 11: Under Option, select the log information you would like to back up (Event 
Log or System Log), and then click OK.

Note: The backup cannot exceed 7 days of recordings. 
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Delete Recorded File(s)

Step 1: Click New Period to open Select Date Time Period.

Step 2: Follow steps 3-7 from the previous two pages to select the data period which you want to delete.

Step 3: Click on the Delete icon to remove all the data in the backup list from the database.

 Note: The deleted video cannot be recovered.
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Remote Live Viewer
With Remote Live Viewer, remote users may watch up to, totally 128  real-time video channels from remote live streaming servers.
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Click the General Settings icon in the Main Console to open the Settings window.

Setting

General Setting

Audio Preview
Enable audio on active channel: Select to enable the audio streaming on active channel.

Miscellaneous
Select to prevent tearing that may occur in the video display. However, this will increase the CPU processing load.
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Server Setting

Step 1: Enter the Server Name as preference.

Step 2: Enter the IP Address, Port, User Name, Password to log in to the server. 

Step 3: Enable Save Password to login without entering the password again. 

Step 4: Enable Auto Login to login automatically when starting the Remote Live Viewer.

Step 5: Click Test Server to check if the server is available.

Step 6: Click Add to insert the setting to server list.

 Note: To remove the server, select a server in the server list and then click Delete.
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Group Setting

Allocate different cameras into groups.

Step 1: Log in to all the servers that contain camera(s) you would like to add into the group(s).

Step 2: Click Insert to create and name a new group.

Step 3: Highlight the camera that you would like to add to a group and then click on <-- . Repeat the process until all the cameras you 
want in the group are added.

Step 4: Click Delete to remove a specific group or click Rename to change the name of a specific group.

Step 5: Click OK to save your group.
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OSD Setting

Select the font style and color for the information displayed on the video.
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Monitor Display Setting

Activate auto scan to rotate the channels/cameras on the display window. For instance, you may select to show only 4 sub-screens on 
the live viewer while having 16 channels connected to the system.  

Step 1: Select the monitor connected to the system.

Step 2: From the Auto scan group drop-down, select a group.

Step 3: Select a primary channel that will always be on the screen when activating auto scan settings.

Step 4: Select a channel that has secondary priority then primary channel on the display screen when activating auto scan settings.

Step 5: From the Layout drop-down, select the screen division you want to display. 
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Notification Settings

Status display

Show recording status: Select to display the recording status on the monitor display.

Show camera event: Select to display detected events on each channel.
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Server/Group/Camera

Click on the Server and Group icon in the Main Console to display a complete list of the server(s), group(s), and camera(s) that are added 
to the system.

Server View                             Group View

Server View: Displays cameras sorted by servers.

Group View: Displays cameras sorted by group names. 
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Option 1: Select a server on the list and then click on the Log In icon to access or 
the Log Out icon to leave the server.

Option 2: On the server list, right-click to open the menu options.

Login/Logout Server

Connect/Disconnect Camera

Option 1: On the server/camera list, double-click on a camera to connect it.

Option 2: On the server/camera list, right-click on a camera to open the menu 
options to connect/disconnect.

Log In/Log Out Server

Connect/Disconnect 
Camera
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Option 3: Select a camera from the list and drag it to where you want the image to be displayed.

Option 4: Play / Stop/ Drop: Select a camera/video and click this button to play/stop/disconnect a particular channel.

Play Stop Drop
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Control the movement of PTZ cameras. With cameras that support PTZ control, you can move, zoom, patrol, adjust the focus, and set 
preset points of the cameras.

Adjust the camera view and click on the Set icon and save the view as preset point 01. Adjust the camera view again and set the preset 
point 02. Repeat the process until you finish setting up all the preset points. Enter a name instead of preset point 01. Click on the Go icon 
to view the preset points.

Note: To change the speed settings of your PTZ camera, click on Main Console > General Setting > Setting > PTZ Config.

Zoom

Click on the + and – signs to zoom in and zoom out the view.

Focus

To focus near means objects that are closer will be clearer than the objects that are further away. On contrast, to focus far means objects 
that are further will be clearer than the objects that are closer. Click on the Focus icon and select auto focus if you want the system to 
decide the focus point for you.

Patrol

To have your PTZ camera to patrol around pre-defined path of preset points, please click Patrol to start/stop patrol.

Note: To setup a patrol path, please go to Main Console > General Setting > Setting  > PTZ Config > Patrol.

PTZ Control

Preset/Go
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On Screen Menu

Right-click on the camera screen and get the On Screen menu, to quickly adjust the setting of camera.

Enable Move

This function allows you to use your mouse to control the PTZ functions of a camera by clicking on the display screen. To enable, click 
Enable Move. To disable, click Disable Move.  

Enable Digital PTZ

Select to enable the digital PTZ functions of the video. Use your mouse wheel or click on the + and – signs to zoom in and zoom out on 
the camera. The square flashing on the video grid indicates the corresponding view of the camera.

Enable Audio

Select to enable audio transmission along with video stream. 

Snapshot

The snapshot function captures a specific video image to the clipboard or to a file that you can save to your computer. 

Toggle Fullscreen

Switch to view video with fullscreen display. To disable this function, right-click on screen and uncheck this option or simply press ESC to 
go back to the original window.
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Playback

Select to open the Playback console and view video remotely.

Add Remote Playback Site

Click the Remote Sever icon        to open the remote playback site management, and 
to add and setup the remote playback site.

Step 1: Enter the IP Address, Port, Username, and Password.

Step 2: Click Add to add the server.

Step 3: Click OK to exit the Setting window.

Access Remote Playback Site

Go to Date/Time and click            on the top of the display window to access the Remote Playback Site.
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Select Open E-Map to open the E-Map window.  

Select to open the I/O control window. This window allows you to control DO devices remotely.

Note: Adjust the setting of I/O device in Main Console > General Setting > Setting > I/O Device first, 
and the I/O control window will display the device status based on these settings. 

Start Monitor

E-Map

I/O Control

Map Select the map you want to show on E-Map Window.

Camera Select the camera you want to preview video and mark an indicator on E-map.

Digital Input
Select to highlight the device with a green circle on the map and show status on the Information 
window. If the Digital Input is from a network camera, the preview window will display live video from 
the camera.

Digital Output
Select to highlight the device with a green circle on the map and show status on the Information 
window. If the Digital Output is from a network camera, the preview window will display live video 
from the camera.
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Web View
Note: Be sure to enable the Live Streaming Server. To enable, go to General Setting > Network Service select Live Streaming and 
click Start Server.

Server IP
Open Internet Explorer and enter the IP address or DDNS name of the server followed by the connecting port. 
Example: http://192.168.1.16:8080/
192.168.1.16 is the IP address of the server. 8080 is the port specified in Use Default Web Server in Network Service.

Note: Make sure the Live Stream Server is enabled. Please refer to Live Streaming Server  for more information. 
 Web View is only supported by Microsoft Internet Explorer versions 7 to 9 (32 bits).
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Utilities
Verification Tool

The Verification Tool verifies whether the data created by the system be tampered with or not. It is the process by which a digital watermark 
(a digital signature) is added to each recorded video frame to ensure its authenticity. 

The 3 types of data that is verified by the Verification Tool are:
1. File in (.dat) (.264) format will be displayed as   .
2. File in (.avi) (.asf) format will be displayed as  .
3. File in (.bmp) (.jpg) format will be displayed as  .

Step 1: Go to Start > All Programs >  D-Link D-ViewCam Standard/
Professional/Enterprise > Verification Tool. 
                                                        
                                                               

Step 2: Enter the Username and Password to log in.
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Overview                                       

         Add File: Click to insert a file to the list for verification. 

         Add Folder: Click to choose a folder with multiple files and then add it to the list for verification.

  Remove File: Click to remove the selected file(s) from the list. 

  Select All: Click to select all the files in the list for verification. 

Note: 
1. Choose the file type first (.dat, .264, .avi, .asf, .bmp, .jpg) before selecting the files. 
2. You can also drag files to the list for verification.
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Video Preview: To preview the selected file from the verification list. Use Play, Verify, Pause and Stop for preview.

Note: Preview of .bmp and .jpg formats are not allowed. 

Verifying Image/Video
Step 1: Select a single or multiple files for verification.

Step 2: Click verify  to start verification.

Step 3: The verification results will be displayed in the Watermark column. 

Note: If the file passes the verification, it will show .

Note: If the file was tampered with, it will show .

Step 4: The Status and Verify fields will display the information related to verification.
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License Management  Tool

Use the License Management Tool to activate the software license from a serial number allocated with the software package, or de-
activate the license and activate it again in another PC.

The following lists 4 types of license management process:

• To “activate” the license with PC connected to the network, follow the Activation On line process.
• To “activate” the license with PC not connected to the network, follow the Activation Off line process.
• To “de-activate/transfer” the license with PC connected to the network, follow the Transfer On line process.
• To “de-activate/transfer” the license with PC not connected to network, follow the Transfer Off line process.

Overview

Step 1: Click License Manager in General Setting or browse the installation folder and click Activate Tool.exe. 

Start License Management
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The License Manager Tool screen displays.

Activate / Transfer License 

Activation On line

Step 1: Start the License Manager Tool.

Step 2: Select On line as Activate type.

Step 3: Enter the SN (Serial number) or Import SN file, and then click Activate.

Step 4: Restart the Main Console if activation is successful.
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Activation Off line

Step 1: Start the License Manager Tool.

Step 2: Select Off line as Activate type.

Step 3: Enter the SN (Serial number) and then click Activate.

Step 4: Save the Request File, and then copy it to another PC connected to Internet.

Step 5: Browse and run Off LineTool.exe , and then click Activate to send the Request File to the license server.
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Step 6: Save this License file, and then copy it to the D-ViewCam Standard/Professional/Enterprise server.

Step 7: Open License Manager Tool again, select Import license file, and then click Activate.

Step 8: Restart the MainConsole if the activation was successful.
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Transfer License 

Transfer On line

Step 1: Start the License Manager Tool.

Step 2: Select Transfer, and then select On line as Transfer type.

Step 3: Enter the SN (Serial number) and then click Transfer.

Step 4: Restart the Main Console if activation is successful.

Transfer Off line

Step 1: Start the License Manager Tool.

Step 2: Select Transfer, and then select Off line as Transfer type.

Step 3: Enter the SN (Serial number) and then click Transfer.
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Step 4: Save the Request File and restart the MainConsole if activation 
is successful.

Step 5: Copy the Request File to another PC connected to internet. 

Step 6: Run OffLineTool.exe, select Transfer SN and click Transfer 
to send the Request File to the license server.

Note: Ensure to copy the request file to another PC and then send it 
to the license server, otherwise the SN cannot be re-activated again.

Step 7: Check if the transfer is complete.
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DB Tool

Step 1: Execute DB Tools from the Start menu. 

Step 2: Enter the administrator password and click OK to log in.
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Repair Database

This window has three repair methods: Modify Location, Verify Only, and Repair.

Modify Location
The Playback system can recognize all the recording videos which are listed list on Main Console > General Setting > Setting > General 
> Storage. Users need to use the Playback system to open recording video beyond storage location setting. 

Note: The default storage location is in your installation directory, (ex: C:\Program Files\SCB_IP).

Step 1: Select Repair Database.

Step 2: Select Modify Location from the Method drop-down menu.
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Step 3: Click       and select a new location.
 To remove a database location, select it from the list and click        to delete location.

Step 4: Click Modify to save the location.
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Example of modify database

To transfer video from one PC to another, follow this procedure:

1. Manually copy all recorded video data files from the default installation path or other user-defined storage path of the old PC.

2. Manually paste all recorded video files to the default installation path or other user-defined storage path of the new PC.

3. Follow the previous page to add new location on new PC.

4. Old recorded video data can be viewed by the playback system on the new PC.

Verify and Repair

This tool is used to check and repair your database and recording video if the problems below exist:

(1) If there are records in database, but no video file, use DB Tools to delete records.
(2) If there are video files but no record in database, use DB Tools to rearrange the database and find these records.
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Step 1: Switch to Repair Database.

Step 2: Select Modify Location from the Method drop-down menu.

Step 3: Check the video location. The system will list all the video locations in the table, but if there are any missing locations, please use
                        to insert a location. After inserting the location, the system will show a file count in the table.

Step 4: Select Verify Only and then click Verify. This method will only check the files without modifying. The Verify Result will show how 
many files are broken or missing.
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Step 5: Choose the method of Repair (Complete), and click Repair. The Repair Result will show the number of files that are fixed and 
inserted.

Step 6: The repair new database will replace the old ones. The original database will change file names with extended repair date and 
time as shown below. 

 Note: Open Log is a tool to record repair database recodes. It will recode repair method, file operation, start time, and end time.
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Export Configuration

This tool is used when you want to export all configuration settings to a backup. 

Step 1: Click Export.

Step 2: Select the location you want to export to and type the name of the config file.

Step 3: Click Save.
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How to install Remote Desktop Viewer

Step 1: Insert the Installation CD. 

Step 2: Go to RemoteDesktopViewer and run the Setup.exe file.

How to Start Remote Desktop Viewer

Step 1: Go to Start > All Programs > Remote Desktop Viewer > Remote Desktop Viewer. 

Step 2: Please enter the address, Port, and Password of the server and enable Use 8 bits color level to show steadier screen. 

Step 3: Click OK to start Remote Desktop. 

Remote Desktop  Viewer
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Frequently Asked Questions
1. What languages does the D-ViewCam Standard/Professional/Enterprise software support?

2. How do I set up E-Map?
Go to Main Console > Start Monitor and then click Open E-map.

Step 1: Select the map.
Step 2: Click Browser/Edit Mode.
Step 3: Click Add Map.
Step 4: Choose a map and then enter the map name.

Bulgarian Chinese (Traditional) Chinese (Simplified ) Czech Danish

Dutch English Farsi Finnish French

German Greek Hebrew Hungarian Italian

Japanese Korean Norwegian Polish Portuguese (Brazil)

Portuguese (Portugal) Romanian Russian Serbian Slovakian

Slovenian Spanish Swedish Thai Turkish



152D-Link D-ViewCam Standard/Professional/Enterprise User Manual

Section 4 - FAQs

 

 

  

 

 

1. 

2.

3. 

4.

 

5. 
6. 

7. 

Step 5: Select the Map that you earlier set.
Step 6: Drag and drop the camera or IO device to the map.
Step 7: Click OK to save your settings.
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3. How do I backup video files?

The system allows you can backup video record files into CD/DVD or other drives, and view those videos via playback.exe 
which will also be saved in the backup folder.

Follow these steps to backup your video:

Step 1: Go to Main Console > General Setting > Backup.

Step 2: Click New Period.

Step 3: Set the Start and End Time. 

Step 4: Select the cameras that you want to backup. 

Step 5: Click OK.
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Step 6: Click Backup.

Step 2: Click New Period.

Step 7: Choose a location to backup media. 

Step 8: Select Backup Event Log and Backup System Log. 

Step 9: Click OK. 

Step 10: You can now execute the playback.exe to check 
your backup files. 
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4. How do I enable audio in Live Streaming for IP cameras?

In order to save bandwidth, the default setting for audio is disabled. This function must be enabled manually. Please follow 
the steps given below.

Step 1: Go to General Setting > Setting > General and 
enable Preview Active Channel.

The default channel means the background audio of camera 
channel. 

Step 2: Switch audio channels to hear audio. 

If you choose sub-screen 1, you will hear audio from camera 
1 or if you choose sub-screen 2, you will hear audio from 
camera 2. 

Note: If you don’t choose any sub-screen, you will hear audio 
from the default channel. 
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5. How do I record audio for Network Cameras?

6. How do I change the recording frame rate and the 
resolution for network cameras?

Step 1: Execute Main Console and go to Schedule > Configure 
> enable Record Audio and click OK.

Step 2: Start Recording Schedule.

Step 1: Open Main Console and go to General Setting > Setting 
> Camera.

Step 2: Select the camera to change the frame rate.
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7. How do I set multiple storage paths for video recording?

   The Main Console allows you to set up several hard disk drives as storage. When the first hard disk is almost full (the
   capacity is less than 800MB on system disks or 100MB on non-system disks), the Main Console will try to find a second 
   storage with enough capaity. If it is not available, then the system will start recycling the data, if auto-recycling is 
   enabled.

   Go to Main Console > Setting > General > Storage Location to modify your settings. 

Step 3: Click Camera Settings to change the frame rate, resolution, 
and quality.
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8. Why do I see “Disk space is low and the scheduler has been shut
    down. Please check the storage location setting to recover”?

Please follow the steps below to solve this issue.
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9. Why do I get “Live streaming server can not be connected” message?

In general, this error message is caused by network problem, so always 
check your network connection first. 
If you are connecting to a remote server or device through WAN. Please 
make sure the remote server or device is not behind a router’s firewall 
or the port is forwarded properly to bypass the router’s firewall. 

Step 1: Verify the following settings and configuration. 
• Ensure the auto recycle, auto login, auto startup and schedule options are enabled in the Main Console.
• Remove NOD32 antivirus since it generates a large amount of log files (.tmp files) that occupy a lot of hard drive space 

and causes the recording to stop.
• Do not adjust the system clock once the recording is started.
• Do not unplug a removable disk when the system is recording. 
• Check if any quota limit is set in your hard drive. 
• Check if the hard drive is set as “read only” or if a folder name “1” exists. 
• Check if the hard drive has bad sectors inside or damaged.
• Make sure you are not using the network hard drive. 

Step 2: Verify if the system stops recording which is caused by insufficient hard drive space. 
• Check if the recording paths are the same in FileRecord.ini and Storage location. 
• Remove the oldest video folders or move them to another hard drive. 
• Check the dberr.log. This log file can be found in D-ViewCam installation folder. If there are a lot of Eventlog and Systemlog 

errors in dberr.log. Eventlog.mdb and Systemlog.mdb might be oversized due to frequent events or scheduler is set as 
record on motion while the cameras focus on a dynamic background. 

• The system’s hard drive space must be more than 800 MB and the data hard drive space must be more than 500 MB 
for recording.

If you still experience this problem, then stop recording and use DB tools to repair/rebuild database.
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10. Why do I get a “Cannot load database template. 
Please re-install the system to solve the problem” 
message?

You will receive this error message if the Mainconsole has 
experienced a critical error when loading the database. 

This problem is frequently observed on Windows Vista 
due to its tightened security system. 

There are two ways to fix this error. 
1.) Turn off UAC in control panel on Windows Vista. 
2.) Enable the privilege level option in compatibility tab 
in Main Console properties. 

11. Why do I get a “Missing or corrupted resource files. Please re-install the 
system to solve the problem” message?

This error message occurs when the software failed to execute the necessary 
file for the requested operation.

1. When loading the Main Console:

The skin files or database may be corrupted to cause this error message. 
Please uninstall the software, and install the latest version.

2. When loading ActiveX of web live viewer/ playback

Please follow the instructions below for troubleshooting. 
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12. Why do I get a “The procedure entry point WMCreateWriter could not be located in the dynamic link library WMVCore.
DLL.” message?

If you see this error message, then please upgrade your windows media player and this problem will be fixed.

Step 1. Turn off UAC in control panel on Windows Vista. 
Step 2. Enable the privilege level option in compatibility tab in Main Console properties. 

Please download the latest Windows media player here, http://www.microsoft.com/windows/windowsmedia/default.mspx.
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13. How do I start network services?

Step 1: Go to General Setting > Network services.

Step 2: Please remember to click on the services you want 
to start in Main Console.
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14. How to configure my PC/Server to allow remote access to Viewer and
 Playback?

In order to view remote live viewer and remote playback from the internet, 
there are two things you have to do.

Step 1: Start Network Service in Main Console. To start, go to Main Console 
> General Setting > Network Service and then start this service. 

• The default port number for live streaming is 5150. 
• The default port number for remote playback is 5160. 
• The default port for web browser is 80. 

If you want to modify, please don’t forget to set it to port forwarding on your 
router. 
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15. Why can’t l see live view and video playback on Internet Explorer after upgrading 
to the latest version?

This is often caused by old temporary IE components in Windows. Please remove 
these IE components and reinstall ActiveX to solve the problem. 

Step 1: Close IE and its related applications first. Otherwise some files may be 
locked during removal. If your OS is Vista, please run “Command prompt” as an 
administrator or you will not be able to remove these components. 

If you see the following error message, this means that your port 80 was 
occupied by the another device, therefore, you have to change the port 
number. 

Step 2: Enable port forwarding in your router and  then find the public IP 
address of your router and set port forwarding on the router to NVR LAN IP. 
• You can see the public IP address of your router in the configuration menu. 
• You can also configure NAT (or port forwarding) port 80, 5150 and 5160 
to your NVR’s LAN IP (e.g. 192.168.3.30) in the router. 
• Port forwarding is similar to the example given below: 
You have to forward 3 ports, one for 80, one for 5150 and one for 5160. 
All 3 ports should point to e.g. 192.168.3.30 

After you have successfully forwarded the 3 ports in your router, you will be 
able to access remote live viewer and remote playback from the internet. 
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Step 2: Go to Start > Run > enter cmd and press OK.

Step 3: Type cd C:\WINDOWS\Downloaded Program Files 
Step 4: Type dir to list all the objects on this folder .

Step 5: Type del /s. 
Note: Don’t forget to add (.) after /s 

Step 6: Keep pressing Y until you are prompted to delete 
all the files in the folder.
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16. What default ports are used for network service?

Step 7: Type rmdir /s . 

Step 8: Continue pressing Y when prompted to clear up the 
remaining files in the folder 

Step 9: Type dir and press Enter to check if the folder 
is empty. 

Step 10: Re-install your ActiveX with web remote client.

The default ports can be changed, but we strongly recommend you avoid using ports below 1024 because  
they are often used by other system services.

Service  Port Purpose  

Live streaming  5150 

Default web server 80 

Communication between desktop remote live viewer and Main Console

Access protocol of web based remote client
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17. How to enable audio for the remote live viewer application and
 Internet Explorer browser?

Remote playback  5160 

Remote desktop  5140   

Communication between desktop remote playback and Main Console

Remote access to Main Console

Please right click on the screen and select Enable Audio.

If you are using network cameras, go to Main Console > General 
Setting > Setting > Camera > Camera Settings.
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Right click on the screen and select Enable Audio.

If you are using analog cameras, please go to Main Console > 
General Setting > Setting > Audio Preview.

Go to remote live viewer and right click on the screen to check 
Enable Audio.
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18. Why Internet Explorer 8 doesn’t work well with software version 
3.0?

In order to install ActiveX in an IE 8 environment, we need to set up 
the following. 

Ensure vcredist_x86.exe has already been installed. 

Step 1: Add the Server IP into Trusted Web Site. 
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Step 2: Add the Server IP Compatibility View Setting  
 
 

      

 

 

 

Step 2: Go to Tools > Compatibility View Settings and add the Server IP Compatibility View Setting. 
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Enjoy 3.2 web live viewer with Internet Explorer 8.
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Step 3: If the instructions above doesn’t work, please try the following method. (Optional)
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19. What is the version of my software?

20. How do I get the Windows system log and application log?

Go to Main Console > General Setting > About Mainconsole.

System log 
Step 1: Go to Desktop > right click on My Computer > Manage.

Step 2: In Computer Management, go to System Tools > Event 
Viewer > System.
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Step 3: Right click on System > Save Log File As...

Step 4: Type system as file name and save file as .evt format 
Please name the file as system so we know that it is a 
system log file. 
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Application Log 
Step 1: Go to Desktop > right click on My Computer > 
Manage.

Step 2: In Computer Management > System Tools > Event 
Viewer > Application. 

Step 3: Right click on Application > Save Log File As... 
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21. How many user accounts can I create?

You can create an unlimited number of user accounts.

22. How do I setup local area network?
D-ViewCam Standard/Professional/Enterprise supports both LAN 
and WAN. If your surveillance system does not have internet access, 
you can setup a private network or LAN to establish networking 
between Mainconsole and other network devices such as an IP 
camera.

Setup with static IP 
Step 1: Go to Control Panel > Network Connections.

Step 4: Type application as file name and save file in .evt 
format. 

Note: Please name the file as application so we know that 
it is an application log file. 
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Step 2: Right click on Local Area Connection > Properties.

Step 3: Select  Internet Protocol(TCP/IP) > Properties.
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23. What should I do when I see this pop-up UAC message?

When using Windows Vista, the system will pop-up the 
following message to stop your D-ViewCam.

Step 4: Select Use the following IP address and update the fields as shown in 
the picture. [192.168.1.1] and [192.168.1.254] is normally occupied by the router 
or other network devices, so please try to avoid using these IP addresses. 

Please note that you will only be able to access IP addresses between the same 
subnet address, such as [192.168.1.1 to 192.168.1.254]. 

Setup with dynamic IP 
We strongly discourage assigning dynamic IP address to IP cameras that are based 
on DHCP. The IP address of each IP camera is temporary so whenever the address 
is reassigned, the camera will lose connection permanently to your D-ViewCam 
Standard/Professional/Enterprise server unless you manually rematch the camera’s 
new IP address to D-ViewCam Standard/Professional/Enterprise server.
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1.) Go to Control Panel.

2.) Click on User Accounts.
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2.) Click on User Accounts.

4.) Click Turn User Account Control on or off.



184D-Link D-ViewCam Standard/Professional/Enterprise User Manual

Section 4 - FAQs

 

 

 

 

 

 

 

24. What type of network does the D-ViewCam Standard/Professional/Enterprise support?

D-ViewCam Standard/Professional/Enterprise supports both LAN and WAN. If your surveillance system does not have internet 
access, you can setup a private network or LAN to establish connection between the Main Console and other network devices 
such as network camera.
 

5.) Click to deselect Use User Account Control (UAC) to 
help protect your computer. 

6.) Click OK and restart Windows. 
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D-ViewCam Standard/Professional/Enterprise product makes use of the following software licensed under LGPL 
(Lesser General Public License). You can download the copies of the LGPL licensed software from the official web 
site listed as the following. 

1.1 LIVE555 Streaming Media (www.live555.com/liveMedia/, GPL v2)
© 1991, 1999 Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA Everyone 
is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed. 

1.2 ffmpeg v51.46.0 (www.ffmpeg.org, GPL v2)
© 1991, 1999 Free Software Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA Everyone 
is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

1.3 FAAC v20020104 (sourceforge.net/projects/faac, GPL v2)
© 1991 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA Everyone is 
permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION 

This License Agreement applies to any software library or other program which contains a notice placed by the 
copyright holder or other authorized party saying it may be distributed under the terms of this Lesser General Public 
License (also called “this License”). Each licensee is addressed as “you”.

A “library” means a collection of software functions and/or data prepared so as to be conveniently linked with application 
programs (which use some of those functions and data) to form executables.

The “Library”, below, refers to any such software library or work which has been distributed under these terms.  A 
“work based on the Library” means either the Library or any derivative work under copyright law: that is to say, a work 
containing the Library or a portion of it, either verbatim or with modifications and/or translated straightforwardly into 

Open Source Software Notification
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another language.  (Hereinafter, translation is included without limitation in the term “modification”.)

“Source code” for a work means the preferred form of the work for making modifications to it.  For a library, complete 
source code means all the source code for all modules it contains, plus any associated interface definition files, plus 
the scripts used to control compilation and installation of the library.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope.  
The act of running a program using the Library is not restricted, and output from such a program is covered only if its 
contents constitute a work based on the Library (independent of the use of the Library in a tool for writing it).  Whether 
that is true depends on what the Library does and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library’s complete source code as you receive it, in any medium, 
provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer 
of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and distribute a 
copy of this License along with the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection 
in exchange for a fee.

2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, 
and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet 
all of these conditions:

a) The modified work must itself be a software library.

b) You must cause the files modified to carry prominent notices     stating that you changed the files and the date 
of any change.

c) You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this 
License.
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d) If a facility in the modified Library refers to a function or a table of data to be supplied by an application program 
that uses the facility, other than as an argument passed when the facility is invoked, then you must make a 
good faith effort to ensure that, in the event an application does not supply such function or table, the facility still 
operates, and performs whatever part of    its purpose remains meaningful.

(For example, a function in a library to compute square roots has a purpose that is entirely well-defined independent of 
the application.  Therefore, Subsection 2d requires that any application-supplied function or table used by this function 
must be optional: if the application does not supply it, the square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from 
the Library, and can be reasonably considered independent and separate works in themselves, then this License, 
and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the 
same sections as part of a whole which is a work based on the Library, the distribution of the whole must be on the 
terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every 
part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the 
intent is to exercise the right to control the distribution of derivative or collective works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a work based on the 
Library) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy 
of the Library.  To do this, you must alter all the notices that refer to this License, so that they refer to the ordinary 
GNU General Public License, version 2, instead of to this License.  (If a newer version than version 2 of the ordinary 
GNU General Public License has appeared, then you can specify that version instead if you wish.)  Do not make any 
other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License 
applies to all subsequent copies and derivative works made from that copy.
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This option is useful when you wish to copy part of the code of the Library into a program that is not a library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable 
form under the terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding 
machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium 
customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering equivalent 
access to copy the source code from the same place satisfies the requirement to distribute the source code, even 
though third parties are not compelled to copy the source along with the object code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being 
compiled or linked with it, is called a “work that uses the Library”.  Such a work, in isolation, is not a derivative work 
of the Library, and therefore falls outside the scope of this License.

However, linking a “work that uses the Library” with the Library creates an executable that is a derivative of the Library 
(because it contains portions of the Library), rather than a “work that uses the library”.  The executable is therefore 
covered by this License. Section 6 states terms for distribution of such executables.

When a “work that uses the Library” uses material from a header file that is part of the Library, the object code for the 
work may be a derivative work of the Library even though the source code is not. Whether this is true is especially 
significant if the work can be linked without the Library, or if the work is itself a library. The threshold for this to be true 
is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and 
small inline functions (ten lines or less in length), then the use of the object file is unrestricted, regardless of whether 
it is legally a derivative work. (Executables containing this object code plus portions of the Library will still fall under 
Section 6.)
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Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms 
of Section 6. Any executables containing that work also fall under Section 6, whether or not they are linked directly 
with the Library itself.

6. As an exception to the Sections above, you may also combine or link a “work that uses the Library” with the Library 
to produce a work containing portions of the Library, and distribute that work under terms of your choice, provided 
that the terms permit modification of the work for the customer’s own use and reverse engineering for debugging such 
modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use 
are covered by this License.  You must supply a copy of this License.  If the work during execution displays copyright 
notices, you must include the copyright notice for the Library among them, as well as a reference directing the user 
to the copy of this License.  Also, you must do one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the Library including 
whatever changes were used in the work (which must be distributed under Sections 1 and 2 above); and, if the 
work is an executable linked with the Library, with the complete machine-readable “work that uses the Library”, 
as object code and/or source code, so that the user can modify the Library and then relink to produce a modified 
executable containing the modified Library. (It is understood that the user who changes the contents of definitions 
files in the Library will not necessarily be able to recompile the application to use the modified definitions.)

b) Use a suitable shared library mechanism for linking with the Library.  A suitable mechanism is one that (1) uses at 
run time a copy of the library already present on the user’s computer system, rather than copying library functions 
into the executable, and (2) will operate properly with a modified version of the library, if the user installs one, as 
long as the modified version is interface-compatible with the version that the work was made with.

c) Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified 
in Subsection 6a, above, for a charge no more than the cost of performing this distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to 
copy the above specified materials from the same place. 
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e) Verify that the user has already received a copy of these materials or that you have already sent this user a copy.

For an executable, the required form of the “work that uses the Library” must include any data and utility programs 
needed for reproducing the executable from it. However, as a special exception, the materials to be distributed need 
not include anything that is normally distributed (in either source or binary form) with the major components (compiler, 
kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies 
the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries that do not normally 
accompany the operating system.  Such a contradiction means you cannot use both them and the Library together 
in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a single library together with 
other library facilities not covered by this License, and distribute such a combined library, provided that the separate 
distribution of the work based on the Library and of the other library facilities is otherwise permitted, and provided that 
you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other 
library facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and 
explaining where to find the accompanying uncombined form of the same work.

8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under 
this License. Any attempt otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will 
automatically terminate your rights under this License. However, parties who have received copies, or rights, from 
you under this License will not have their licenses terminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission 
to modify or distribute the Library or its derivative works. These actions are prohibited by law if you do not accept 
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this License. Therefore, by modifying or distributing the Library (or any work based on the Library), you indicate your 
acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Library 
or works based on it.

10. Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives 
a license from the original licensor to copy, distribute, link with or modify the Library subject to these terms and 
conditions. You may not impose any further restrictions on the recipients’ exercise of the rights granted herein. You 
are not responsible for enforcing compliance by third parties with this License.

11. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited 
to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the 
conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to 
satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence 
you may not distribute the Library at all.  For example, if a patent license would not permit royalty-free redistribution 
of the Library by all those who receive copies directly or indirectly through you, then the only way you could satisfy 
both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the 
section is intended to apply, and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest 
validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution 
system which is implemented by public license practices. Many people have made generous contributions to the wide 
range of software distributed through that system in reliance on consistent application of that system; it is up to the 
author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot 
impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

12. If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted 
interfaces, the original copyright holder who places the Library under this License may add an explicit geographical 
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distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus 
excluded.  In such case, this License incorporates the limitation as if written in the body of this License.

13. The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License 
from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address 
new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this License which 
applies to it and “any later version”, you have the option of following the terms and conditions either of that version 
or of any later version published by the Free Software Foundation. If the Library does not specify a license version 
number, you may choose any version ever published by the Free Software Foundation.

14. If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible 
with these, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, 
write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the 
two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse 
of software generally.

NO WARRANTY 

15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, 
TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE 
COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY “AS IS” WITHOUT WARRANTY OF 
ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY 
AND PERFORMANCE OF THE LIBRARY IS WITH YOU.  SHOULD THE LIBRARY PROVE DEFECTIVE, YOU 
ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY 
COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS 
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PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL 
OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE LIBRARY (INCLUDING 
BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED 
BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), 
EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

2. Expat XML parser v2.0.1 (expat.sourceforge.net)
© 1998, 1999, 2000 Thai Open Source Software Center Ltd and Clark Cooper
© 2001, 2002, 2003, 2004, 2005, 2006 Expat maintainers.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated 
documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights 
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons 
to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the 
Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING 
BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY 
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, 
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN 
THE SOFTWARE.

3. OpenSSL v0.9.8.g (www.openssl.org)
The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the original 
SSLeay license apply to the toolkit. See below for the actual license texts. Actually both licenses are BSD-style Open 
Source licenses.
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© 1998-2007 The OpenSSL Project. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following 
conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following 
disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following 
disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgment:
“This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.
openssl.org/)”

4. The names “OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote products derived 
from this software without prior written permission. For written permission, please contact penssl-core@openssl.org.

5. Products derived from this software may not be called “OpenSSL” nor may “OpenSSL” appear in their names 
without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment:
“This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.
openssl.org/)”

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS’’ AND ANY EXPRESSED OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT 
OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON 
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ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE 
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.

4. Crypto++ v5.5.2 (www.cryptopp.com)
© 1995-2006 by Wei Dai. All rights reserved.
This copyright applies only to this software distribution package as a compilation, and does not imply a copyright on 
any particular file in the package.

The following files are copyrighted by their respective original authors, and their use is subject to additional licenses 
included in these files.

mars.cpp - Copyright 1998 Brian Gladman.

All other files in this compilation are placed in the public domain by Wei Dai and other contributors.

I would like to thank the following authors for placing their works into the public domain:

Joan Daemen - 3way.cpp
Leonard Janke - cast.cpp, seal.cpp
Steve Reid - cast.cpp
Phil Karn - des.cpp
Michael Paul Johnson - diamond.cpp
Andrew M. Kuchling - md2.cpp, md4.cpp
Colin Plumb - md5.cpp, md5mac.cpp
Seal Woods - rc6.cpp
Chris Morgan - rijndael.cpp
Paulo Baretto - rijndael.cpp, skipjack.cpp, square.cpp
Richard De Moliner - safer.cpp
Matthew Skala - twofish.cpp
Kevin Springle - camellia.cpp, shacal2.cpp, ttmac.cpp, whrlpool.cpp, ripemd.cpp



196D-Link D-ViewCam Standard/Professional/Enterprise User Manual

Appendix A - Open Source Software Notification

Permission to use, copy, modify, and distribute this compilation for any purpose, including commercial applications, 
is hereby granted without fee, subject to the following restrictions:

1. Any copy or modification of this compilation in any form, except in object code form as part of an application software, 
must include the above copyright notice and this license.

2. Users of this software agree that any modification or extension they provide to Wei Dai will be considered public 
domain and not copyrighted unless it includes an explicit copyright notice.

3. Wei Dai makes no warranty or representation that the operation of the software in this compilation will be error-
free, and Wei Dai is under no obligation to provide any services, by way of maintenance, update, or otherwise. THE 
SOFTWARE AND ANY DOCUMENTATION ARE PROVIDED “AS IS” WITHOUT EXPRESS OR IMPLIED WARRANTY 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE. IN NO EVENT WILL WEI DAI OR ANY OTHER CONTRIBUTOR BE LIABLE FOR DIRECT, 
INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

4. Users will not use Wei Dai or any other contributor’s name in any publicity or advertising, without prior written 
consent in each case.

5. Export of this software from the United States may require a specific license from the United States Government. 
It is the responsibility of any person or organization contemplating export to obtain such a license before exporting.

6. Certain parts of this software may be protected by patents. It is the users’ responsibility to obtain the appropriate 
licenses before using those parts.

If this compilation is used in object code form in an application software, acknowledgement of the author is not required 
but would be appreciated. The contribution of any useful modifications or extensions to Wei Dai is not required but 
would also be appreciated.
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